From a7a9825aa1032c7559674a83916adb0f52f29f7f Mon Sep 17 00:00:00 2001 From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com> Date: Fri, 7 Aug 2026 06:58:17 +0000 Subject: [PATCH] build(deps-dev): update torch requirement from <2.6,>=2.5 to >=2.5,<2.14 Updates the requirements on [torch](https://github.com/pytorch/pytorch) to permit the latest version. - [Release notes](https://github.com/pytorch/pytorch/releases) - [Changelog](https://github.com/pytorch/pytorch/blob/main/RELEASE.md) - [Commits](https://github.com/pytorch/pytorch/compare/v2.5.0...v2.13.0) --- updated-dependencies: - dependency-name: torch dependency-version: 2.13.0 dependency-type: direct:development ... Signed-off-by: dependabot[bot] --- pyproject.toml | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/pyproject.toml b/pyproject.toml index ba70239..c77e7c6 100644 --- a/pyproject.toml +++ b/pyproject.toml @@ -29,12 +29,12 @@ py-modules = ["h8_pipeline"] [project.optional-dependencies] diarization = [ - "torch>=2.5,<2.6", + "torch>=2.5,<2.14", "torchaudio>=2.5,<2.6", "pyannote.audio>=3.3.0,<4", ] nvidia = [ - "torch>=2.5,<2.6", + "torch>=2.5,<2.14", "torchaudio>=2.5,<2.6", "nemo_toolkit[asr]>=2.2.0", ]