From 3b9aa3f663fbfa3099eff0839fe6067324b07928 Mon Sep 17 00:00:00 2001 From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com> Date: Fri, 11 Sep 2026 22:35:30 +0000 Subject: [PATCH] build(deps-dev): update torch requirement from <2.6,>=2.5 to >=2.5,<2.15 Updates the requirements on [torch](https://github.com/pytorch/pytorch) to permit the latest version. - [Release notes](https://github.com/pytorch/pytorch/releases) - [Changelog](https://github.com/pytorch/pytorch/blob/main/RELEASE.md) - [Commits](https://github.com/pytorch/pytorch/compare/v2.5.0...v2.14.0) --- updated-dependencies: - dependency-name: torch dependency-version: 2.14.0 dependency-type: direct:development ... Signed-off-by: dependabot[bot] --- pyproject.toml | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/pyproject.toml b/pyproject.toml index ba70239..39625ef 100644 --- a/pyproject.toml +++ b/pyproject.toml @@ -29,12 +29,12 @@ py-modules = ["h8_pipeline"] [project.optional-dependencies] diarization = [ - "torch>=2.5,<2.6", + "torch>=2.5,<2.15", "torchaudio>=2.5,<2.6", "pyannote.audio>=3.3.0,<4", ] nvidia = [ - "torch>=2.5,<2.6", + "torch>=2.5,<2.15", "torchaudio>=2.5,<2.6", "nemo_toolkit[asr]>=2.2.0", ]