Repository navigation
Conversation
Minimal same-major upgrades for vulnerable dependencies reported by pnpm audit. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com> Claude-Session: https://claude.ai/code/session_014XqKqjvyaMENCpGUFQqRHd
Owner
Author
|
Automated review — not merged. Diff reviewed: 1 critical + 51 high → 1 high. Fixed a pre-existing override (
Generated by Claude Code |
41.x has no patched release for this high advisory. better-sqlite3 12.10.1 is the minimum that rebuilds against Electron 42 V8 headers. Co-authored-by: Ruben Glez. <RubenGlez@users.noreply.github.com>
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Summary
Patches critical and high severity vulnerabilities reported by
pnpm audit, using the smallest upgrade within the same major version (no breaking major bumps).package.json.overrides(only the vulnerable range is redirected).dompurify@xmldom/xmldom@xmldom/xmldomundicinanoid@xmldom/xmldomundici@xmldom/xmldom@xmldom/xmldomundicivitefast-urisource-map-jsbrace-expansion@xmldom/xmldombrowserslistfast-uri@xmldom/xmldom@xmldom/xmldom@xmldom/xmldom@xmldom/xmldom@xmldom/xmldom@xmldom/xmldomelectronelectron@xmldom/xmldom@xmldom/xmldombrowserslistfast-urifast-uri@xmldom/xmldomelectronelectronelectronfast-urizoddompurifybrace-expansionundicifast-uritarundicibrace-expansion@xmldom/xmldomundici@xmldom/xmldom@xmldom/xmldom@xmldom/xmldomundiciNot fixed (requires a major upgrade)
electronextract-zipVerification
pnpm audit: 1 critical + 51 high → 0 critical, 1 high remaining (electron 41 → needs 42)undici@<6.27.0:>=6.27.0→^6.27.0. The open-ended range was resolving node-gyp's undici (declared ^6.25.0) to vulnerable 8.5.0; it now gets 6.29.1.brace-expansion5.0.8 → 5.0.12,tar^7.5.16 → ^7.5.21tsc✅lint✅test✅vite build✅ (fullbuildfails at electron-builder packaging because package.jsonauthorhas no email — unrelated, same on main)Generated by Claude Code
Summary
Patches critical and high severity vulnerabilities reported by
pnpm auditand OSV. Same-major upgrades and scoped overrides where a patched release exists. The one remaining high, ElectronGHSA-jr5w-w6x2-84p9, has no 41.x fix and is bumped to the first patched release,42.11.16.package.json.overrides(only the vulnerable range is redirected).dompurify@xmldom/xmldom@xmldom/xmldomundicinanoid@xmldom/xmldomundici@xmldom/xmldom@xmldom/xmldomundicivitefast-urisource-map-jsbrace-expansion@xmldom/xmldombrowserslistfast-uri@xmldom/xmldom@xmldom/xmldom@xmldom/xmldom@xmldom/xmldom@xmldom/xmldom@xmldom/xmldomelectronelectron@xmldom/xmldom@xmldom/xmldombrowserslistfast-urifast-uri@xmldom/xmldomelectronelectronelectronfast-urielectronzoddompurifybrace-expansionundicifast-uritarundicibrace-expansion@xmldom/xmldomundici@xmldom/xmldom@xmldom/xmldom@xmldom/xmldomundiciFollow-up (
b24a653)dependency-reviewfailed on4cfad47becauseelectron@41.10.6still matched GHSA-jr5w-w6x2-84p9 / CVE-2026-115570 (high; patched< 42.11.16→42.11.16).41.10.7is inside the same range. The same package also carried the moderate/low advisories that the gate reports at its defaultlowthreshold; those patch lines are all older than42.11.16, so they clear with this bump.better-sqlite3moves^12.10.0→^12.10.1(locked at12.10.1).12.10.0does not compile against Electron 42 V8 headers (WiseLibs/better-sqlite3#1475, merged in12.10.1).electron-rebuild -f -w better-sqlite3completes.extract-zipis not in the lockfile. The tree has@electron-internal/extract-zip@1.0.8, which OSV does not list. npmextract-zipstops at2.0.1; GHSA-jmr9-qjv8-65gv and GHSA-7pqw-9j4j-h8q3 havefirst_patched_version: nullandlast_affected: 2.0.1.pnpm auditdoes not report that package.Left at moderate (out of scope)
pnpm auditafter this bump: 0 critical, 0 high, 6 moderate (fflate,vitest/@vitest/mocker,js-yaml,minimatch). OSV agrees there is no remaining advisory labeled high or critical. These were not changed.Verification
tsc,lint,vitest(19),vite build,electron-rebuildforbetter-sqlite3.pnpm audit --audit-level=highand--prod: exit 0.b24a653172ca4f51c527d50343a0142ca98df49c:checksuccess,dependency-reviewsuccess (no vulnerable packages at low or higher).Not merged.