The installation of signalk-node-red in my SignalK Docker instance worked fine until very recently.
On server startup it now complains:
Aug 13 08:48:55 @signalk/signalk-node-red failed to start: Cannot find module 'moment'
Aug 13 08:48:55 { Error: Cannot find module 'moment'
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
at Function.Module._load (internal/modules/cjs/loader.js:562:25)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at /home/node/.signalk/node_modules/@node-red/util/node_modules/moment-timezone/moment-timezone.js:12:28
at Object.<anonymous> (/home/node/.signalk/node_modules/@node-red/util/node_modules/moment-timezone/moment-timezone.js:18:2)
at Module._compile (internal/modules/cjs/loader.js:778:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at Object.<anonymous> (/home/node/.signalk/node_modules/@node-red/util/node_modules/moment-timezone/index.js:1:31)
at Module._compile (internal/modules/cjs/loader.js:778:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at Object.<anonymous> (/home/node/.signalk/node_modules/@node-red/util/lib/util.js:24:16) code: 'MODULE_NOT_FOUND'
Background: this is a quite new SignalK installation (Docker, arm64) which I am currently configuring.
Immediately before this error occurred I deinstalled the InfluxDB writer module and installed the InfluxDB2 writer module. After the server restart node-red-embedded reported this error (however I have no idea how this could be the cause of the problem.)
The installation of signalk-node-red in my SignalK Docker instance worked fine until very recently.
On server startup it now complains:
Background: this is a quite new SignalK installation (Docker, arm64) which I am currently configuring.
Immediately before this error occurred I deinstalled the InfluxDB writer module and installed the InfluxDB2 writer module. After the server restart node-red-embedded reported this error (however I have no idea how this could be the cause of the problem.)