Skip to content

When using an exec command the sftp subsystem is not set #48

Description

@chriskinsman

Ran into this when using against a locked down server.

Sending / Receiving files worked but random SFTP commands send via the command option would fail with an error message that the server only support sftp.

From the sftp CLI which set the subsystem everything worked great. Looks like SSH2 has the ability to set the subsystem.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions