Skip to content
Kenneth Skovhede edited this page Aug 26, 2016 · 9 revisions

Duplicati FAQ

This page contains frequently asked questions, and serves as a place to contain those answers

Q: Can Duplicati store plain files instead of inside compressed folders?

A: No. Duplicati is a backup tool, not a file sync tool. If you simply sync your files, you need to be certain that the system that you are storing the files on can handle the same as your local files. For example you cannot store data from a case-sensitive filesystem on a server with a case-insensitive file system.

You also need a server-side handler that can update the remote files, otherwise you need to transfer complete files every time something changes. Duplicati is designed so it does not require any code installed on the remote machine.

If you store plain files on the server, you loose confidentiality as all filenames and file sizes are readable.

However, if this is what you want, you can search for "file mirror tool" or "file sync tool". Some open source projects that look interesting: Rclone, SparkleShare, Mirall, OwnCloud, cSync, S3 File Sync. There are many commercial solutions as well.


Q: I get a message like: remote file duplicati-abcdef.dindex.zip.aes is listed as Verified with size 200000 but should be -1, please verify the sha256 hash "". What does it mean?

A: Duplicati version 2.0 keeps track of the state of remote files. Due to a bug this was not correctly handled until version 2.0.0.65. To remedy this, a check was added to 2.0.0.65 that discovers when the remote file was not registered correctly.

Running the "repair" or "verify" command should fix the issue.


Q: I get an error message about sandboxing, and Duplicati will not run?

A: This is caused by unpacking a zip file. This problem will be resolved once Duplicati has MSI installers.

To resolve it, delete the folder where you unpacked Duplicati, then remove the "Blocked" attribute from the zip file. To do this, right click the zip, choose "Properties" and then click the Unblock button. Now you can extract the files from the zip archive without issues.

The error message reads something like: "An attempt was made to load an assembly from a network location which would have" " caused the assembly to be sandboxed in previous versions of the .NET Framework."

A thread discussing the Windows "feature" can be found here: https://superuser.com/questions/38476/this-file-came-from-another-computer-how-can-i-unblock-all-the-files-in-a


Q: SkyDrive / OneDrive does not work?

A: Microsoft changed something in their service after the change to the name OneDrive. This change broke support for OneDrive in Duplicati, but has been fixed in Duplicati 2.0. No fix is available for 1.3.x, you can use a workaround where you mount OneDrive as a WebDAV folder: http://blog.lazut.in/2012/12/skydrive-webdav-access.html


Q: Is 1.3.x dead?

A: Yes. We do not have the man-power to maintain 1.3.x and develop 2.0. You can continue to use it, but we do not develop on it ourselves, as we have chosen to focus on 2.0. Feel free to checkout the 1.3.x branch if you want to continue the development of that version.


Q: Can I please translate the user interface to my favorite language?

A: Not yet. We are not at a place where the UI is stable enough to translate. We do not have a format or a method for applying the translations.


Q: Duplicati wont't run on Synology?

A: That is a bug with the Mono package on Synology. They have acknowledged the problem. To see if you have the same issue, try running: > file /var/packages/Mono/target/lib/libMonoPosixHelper.so

If you get:

/var/packages/Mono/target/lib/libMonoPosixHelper.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped

Then your Mono installation is flawed.

If you get:

/var/packages/Mono/target/lib/libMonoPosixHelper.so: ELF 32-bit LSB shared object, ARM, EABI5 version 1 (SYSV), dynamically linked, stripped

You should be alright.

If you have the wrong versions and are comfortable replacing them, the correct versions are here: https://dl.dropboxusercontent.com/u/15251537/libMonoPosixHelper.so https://dl.dropboxusercontent.com/u/15251537/libMonoSupportW.so

Also, further adventures into getting Mono on Synology can be found here: http://blog.hexad.dk/2013/11/mono-323-on-synology-ds210.html


Q: On Windows, I do get many access denied error messages in my Duplicati2 log

A: By default, Duplicati does not use Shadow Copies, Allow Duplicati to use Shadow Copies to fix the issue.

  1. Edit your backup configuration

  2. Select the Options Tab

  3. Find the Options field and add this line: --snapshot-policy=auto

  4. Don't forget to save your change.

From the Duplicati command line help (v2.0.65): snapshot-policy : Controls the use of disk snapshots Type: Enumeration, Default value: off This settings controls the usage of snapshots, which allows Duplicati to backup files that are locked by other programs. If this is set to "off", Duplicati will not attempt to create a disk snapshot. Setting this to "auto" makes Duplicati attempt to create a snapshot, and fail silently if that was not allowed or supported. A setting of "on" will also make Duplicati attempt to create a snapshot, but will produce a warning message in the log if it fails. Setting it to "required" will make Duplicati abort the backup if the snapshot creation fails. On windows this uses the Volume Shadow Copy Services (VSS) and requires administrative privileges. On linux this uses Logical Volume Management (LVM) and requires root privileges.

Clone this wiki locally